在linux上安装和使用v2ray客户端

sudo su
bash <(curl -L -s https://install.direct/go.sh)

将自己的配置文件复制到需要的位置

sudo cp config.json /etc/v2ray/config.json
sudo chmod 777 /etc/v2ray/config.json
service v2ray start    //启动v2ray
 
service v2ray status   //查看v2ray状态
 
service v2ray stop     //停止v2ray

然后浏览器想用,可以全局代理,也可以插件代理。

如果命令行想用代理,可以继续看下面

安装proxychains

sudo apt install proxychains

配置proxychains

sudo vim /etc/proxychains.conf
  • 在proxychains.conf文件末尾修改你的socks5服务地址,可以把sock4删除

    [ProxyList]
    socks5 127.0.0.1 1080

使用(此方法只能代理TCP链接)

在 命令之前加上 proxychains 即可使用

proxychains pip install <package_name>
proxychains apt-get update


当我执行的时候出错了

ERROR: ld.so: object 'libproxychains.so.3' from LD_PRELOAD cannot be preloaded
首先

find /usr/ -name libproxychains.so.3 -print

看看这个库文件在哪,我的在这里

/usr/lib/x86_64-linux-gnu/libproxychains.so.3

然后打开配置文件修改成我们库的位置

sudo gedit /usr/bin/proxychains

就能正常使用了。

最后修改:2020 年 07 月 09 日 07 : 08 PM
如果觉得我的文章对你有用,请随意赞赏